import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\s|\\()like(\\s|\\))\\s*\\(('((\\w|%|'{2})]*)')\\s*\\+\\s?@p\\d+\\s*\\+('%')\\)";
final String string = "where ( i like 'b' ) and concat(a,b) like ('%'+@p2+'%')\n\n\n"
+ " a + 'b' like ('%'+@p2+'%')\n"
+ " concat(a,b) like ('%'+@p2+'%') or ltrim(a) like ('%'+@p2+'%')\n"
+ "select * from a where concat(a,b) like 'a' and c like d or ltrim(a) like ('%'+@p2+'%')";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}