re = /(\s|\()like(\s|\))\s*\(('((\w|%|'{2})]*)')\s*\+\s?@p\d+\s*\+('%')\)/i
str = 'where ( i like \'b\' ) and concat(a,b) like (\'%\'+@p2+\'%\')
a + \'b\' like (\'%\'+@p2+\'%\')
concat(a,b) like (\'%\'+@p2+\'%\') or ltrim(a) like (\'%\'+@p2+\'%\')
select * from a where concat(a,b) like \'a\' and c like d or ltrim(a) like (\'%\'+@p2+\'%\')'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end