const regex = /(\s|\()like(\s|\))\s*\(('((\w|%|'{2})]*)')\s*\+\s?@p\d+\s*\+('%')\)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\s|\\()like(\\s|\\))\\s*\\((\'((\\w|%|\'{2})]*)\')\\s*\\+\\s?@p\\d+\\s*\\+(\'%\')\\)', 'gi')
const str = `where ( i like 'b' ) and concat(a,b) like ('%'+@p2+'%')
a + 'b' like ('%'+@p2+'%')
concat(a,b) like ('%'+@p2+'%') or ltrim(a) like ('%'+@p2+'%')
select * from a where concat(a,b) like 'a' and c like d or ltrim(a) like ('%'+@p2+'%')`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}