// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(\s|\()like(\s|\))\s*\(('((\w|%|'{2})]*)')\s*\+\s?@p\d+\s*\+('%')\)").unwrap();
let string = "where ( i like 'b' ) and concat(a,b) like ('%'+@p2+'%')
a + 'b' like ('%'+@p2+'%')
concat(a,b) like ('%'+@p2+'%') or ltrim(a) like ('%'+@p2+'%')
select * from a where concat(a,b) like 'a' and c like d or ltrim(a) like ('%'+@p2+'%')";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}