#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\$?\E?\-?[\d.,]+\E?\$?"
Local $sString = "Amount: 0.00 ;" & @CRLF & _
"Amount: 10.00 ;" & @CRLF & _
"Amount: 970.50 ;" & @CRLF & _
"Amount: 1,000.80 ;" & @CRLF & _
"Amount: 11,684.87 ;" & @CRLF & _
"Amount: $89.70 ;" & @CRLF & _
"Amount: $101.29 ;" & @CRLF & _
"Amount: $1,740.20 ;" & @CRLF & _
"Amount: $10,650.64 ;" & @CRLF & _
"Amount: E70.84 ;" & @CRLF & _
"Amount: E120.48 ;" & @CRLF & _
"Amount: E-20.00 ;" & @CRLF & _
"Amount: E-145.10 ;" & @CRLF & _
"Amount: -89.00E ;" & @CRLF & _
"Amount: -100.00E ;" & @CRLF & _
"Amount: -594.00$ ;" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")