import Foundation
let pattern = #"\$?\E?\-?[\d.,]+\E?\$?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Amount: 0.00 ;
Amount: 10.00 ;
Amount: 970.50 ;
Amount: 1,000.80 ;
Amount: 11,684.87 ;
Amount: $89.70 ;
Amount: $101.29 ;
Amount: $1,740.20 ;
Amount: $10,650.64 ;
Amount: E70.84 ;
Amount: E120.48 ;
Amount: E-20.00 ;
Amount: E-145.10 ;
Amount: -89.00E ;
Amount: -100.00E ;
Amount: -594.00$ ;
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)