package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\$?\E?\-?[\d.,]+\E?\$?`)
var str = `Amount: 0.00 ;
Amount: 10.00 ;
Amount: 970.50 ;
Amount: 1,000.80 ;
Amount: 11,684.87 ;
Amount: $89.70 ;
Amount: $101.29 ;
Amount: $1,740.20 ;
Amount: $10,650.64 ;
Amount: E70.84 ;
Amount: E120.48 ;
Amount: E-20.00 ;
Amount: E-145.10 ;
Amount: -89.00E ;
Amount: -100.00E ;
Amount: -594.00$ ;
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}