// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\$?\E?\-?[\d.,]+\E?\$?").unwrap();
let string = "Amount: 0.00 ;
Amount: 10.00 ;
Amount: 970.50 ;
Amount: 1,000.80 ;
Amount: 11,684.87 ;
Amount: $89.70 ;
Amount: $101.29 ;
Amount: $1,740.20 ;
Amount: $10,650.64 ;
Amount: E70.84 ;
Amount: E120.48 ;
Amount: E-20.00 ;
Amount: E-145.10 ;
Amount: -89.00E ;
Amount: -100.00E ;
Amount: -594.00$ ;
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}