# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\$?\E?\-?[\d.,]+\E?\$?"
test_str = ("Amount: 0.00 ;\n"
"Amount: 10.00 ;\n"
"Amount: 970.50 ;\n"
"Amount: 1,000.80 ;\n"
"Amount: 11,684.87 ;\n"
"Amount: $89.70 ;\n"
"Amount: $101.29 ;\n"
"Amount: $1,740.20 ;\n"
"Amount: $10,650.64 ;\n"
"Amount: E70.84 ;\n"
"Amount: E120.48 ;\n"
"Amount: E-20.00 ;\n"
"Amount: E-145.10 ;\n"
"Amount: -89.00E ;\n"
"Amount: -100.00E ;\n"
"Amount: -594.00$ ;\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.