import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\$?\\E?\\-?[\\d.,]+\\E?\\$?";
final String string = "Amount: 0.00 ;\n"
+ "Amount: 10.00 ;\n"
+ "Amount: 970.50 ;\n"
+ "Amount: 1,000.80 ;\n"
+ "Amount: 11,684.87 ;\n"
+ "Amount: $89.70 ;\n"
+ "Amount: $101.29 ;\n"
+ "Amount: $1,740.20 ;\n"
+ "Amount: $10,650.64 ;\n"
+ "Amount: E70.84 ;\n"
+ "Amount: E120.48 ;\n"
+ "Amount: E-20.00 ;\n"
+ "Amount: E-145.10 ;\n"
+ "Amount: -89.00E ;\n"
+ "Amount: -100.00E ;\n"
+ "Amount: -594.00$ ;\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}