using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\u0621-\u064A\u0660-\u0669 ]+";
string input = @"بطيبـةَ رسـمٌ للرسـولِ ومعهـدُ منيرٌ ، وقد تعفو الرسـومُ وتهمـد ولا تنمحي الآياتُ من دارِ حرمـةٍ بِها منبرُ الهادي الذي كانَ يصعـدُ وواضحُ آيـاتٍ، وباقـي معالـمٍ وربعٌ لهُ فيـهِ مصلـىً ومسجـدُ بِها حجراتٌ كانَ ينـزلُ وسطهـا منَ اللهِ نـورٌ يستضـاءُ، ويوقـدُ ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}