package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[\u0621-\u064A\u0660-\u0669 ]+`)
var str = `بطيبـةَ رسـمٌ للرسـولِ ومعهـدُ منيرٌ ، وقد تعفو الرسـومُ وتهمـد ولا تنمحي الآياتُ من دارِ حرمـةٍ بِها منبرُ الهادي الذي كانَ يصعـدُ وواضحُ آيـاتٍ، وباقـي معالـمٍ وربعٌ لهُ فيـهِ مصلـىً ومسجـدُ بِها حجراتٌ كانَ ينـزلُ وسطهـا منَ اللهِ نـورٌ يستضـاءُ، ويوقـدُ `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}