# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[\u0621-\u064A\u0660-\u0669 ]+"
test_str = "بطيبـةَ رسـمٌ للرسـولِ ومعهـدُ منيرٌ ، وقد تعفو الرسـومُ وتهمـد ولا تنمحي الآياتُ من دارِ حرمـةٍ بِها منبرُ الهادي الذي كانَ يصعـدُ وواضحُ آيـاتٍ، وباقـي معالـمٍ وربعٌ لهُ فيـهِ مصلـىً ومسجـدُ بِها حجراتٌ كانَ ينـزلُ وسطهـا منَ اللهِ نـورٌ يستضـاءُ، ويوقـدُ "
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.