re = /[\u0621-\u064A\u0660-\u0669 ]+/
str = 'بطيبـةَ رسـمٌ للرسـولِ ومعهـدُ منيرٌ ، وقد تعفو الرسـومُ وتهمـد ولا تنمحي الآياتُ من دارِ حرمـةٍ بِها منبرُ الهادي الذي كانَ يصعـدُ وواضحُ آيـاتٍ، وباقـي معالـمٍ وربعٌ لهُ فيـهِ مصلـىً ومسجـدُ بِها حجراتٌ كانَ ينـزلُ وسطهـا منَ اللهِ نـورٌ يستضـاءُ، ويوقـدُ '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end