import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\u0621-\\u064A\\u0660-\\u0669 ]+";
final String string = "بطيبـةَ رسـمٌ للرسـولِ ومعهـدُ منيرٌ ، وقد تعفو الرسـومُ وتهمـد ولا تنمحي الآياتُ من دارِ حرمـةٍ بِها منبرُ الهادي الذي كانَ يصعـدُ وواضحُ آيـاتٍ، وباقـي معالـمٍ وربعٌ لهُ فيـهِ مصلـىً ومسجـدُ بِها حجراتٌ كانَ ينـزلُ وسطهـا منَ اللهِ نـورٌ يستضـاءُ، ويوقـدُ ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}