#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\[HorribleSubs\])((?P<show>.*?)[ _\-]+)(\((Web|Tv)\)[ _\-]+)?(?P<ep>\d{1,4})(\+(?P<ep2>\d{1,4}))?(v[\d]+)? \["
Local $sString = " Size" & @CRLF & _
"[HorribleSubs] Special 7 - Special Crime Investigation Unit - 02 [1080p].mkv"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")