import Foundation
let pattern = #"(\[HorribleSubs\])((?P<show>.*?)[ _\-]+)(\((Web|Tv)\)[ _\-]+)?(?P<ep>\d{1,4})(\+(?P<ep2>\d{1,4}))?(v[\d]+)? \["#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Size
[HorribleSubs] Special 7 - Special Crime Investigation Unit - 02 [1080p].mkv
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)