re = /(\[HorribleSubs\])((?P<show>.*?)[ _\-]+)(\((Web|Tv)\)[ _\-]+)?(?P<ep>\d{1,4})(\+(?P<ep2>\d{1,4}))?(v[\d]+)? \[/m
str = ' Size
[HorribleSubs] Special 7 - Special Crime Investigation Unit - 02 [1080p].mkv'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end