import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\[HorribleSubs\\])((?P<show>.*?)[ _\\-]+)(\\((Web|Tv)\\)[ _\\-]+)?(?P<ep>\\d{1,4})(\\+(?P<ep2>\\d{1,4}))?(v[\\d]+)? \\[";
final String string = " Size\n"
+ "[HorribleSubs] Special 7 - Special Crime Investigation Unit - 02 [1080p].mkv";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}