// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\[HorribleSubs\])((?P<show>.*?)[ _\-]+)(\((Web|Tv)\)[ _\-]+)?(?P<ep>\d{1,4})(\+(?P<ep2>\d{1,4}))?(v[\d]+)? \[").unwrap();
let string = " Size
[HorribleSubs] Special 7 - Special Crime Investigation Unit - 02 [1080p].mkv";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}