using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\[HorribleSubs\])((?P<show>.*?)[ _\-]+)(\((Web|Tv)\)[ _\-]+)?(?P<ep>\d{1,4})(\+(?P<ep2>\d{1,4}))?(v[\d]+)? \[";
string input = @" Size
[HorribleSubs] Special 7 - Special Crime Investigation Unit - 02 [1080p].mkv";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}