using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"CREATE\sTABLE\s([a-zA-Z0-9\`\_\-]{0,})";
string substitution = @" $0 IF NOT EXISTS (";
string input = @"CREATE TABLE `alarmas` (";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}