import re
regex = re.compile(r"CREATE\sTABLE\s([a-zA-Z0-9\`\_\-]{0,})")
test_str = "CREATE TABLE `alarmas` ("
subst = " $0 IF NOT EXISTS ("
result = regex.sub(subst, test_str, count=1)
if result:
print(result)