import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "CREATE\\sTABLE\\s([a-zA-Z0-9\\`\\_\\-]{0,})";
final String string = "CREATE TABLE `alarmas` (";
final String subst = " $0 IF NOT EXISTS (";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}