use strict;
my $str = 'CREATE TABLE `alarmas` (';
my $regex = qr/CREATE\sTABLE\s([a-zA-Z0-9\`\_\-]{0,})/p;
my $subst = ' $0 IF NOT EXISTS (';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";