// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"CREATE\sTABLE\s([a-zA-Z0-9\`\_\-]{0,})").unwrap();
let string = "CREATE TABLE `alarmas` (";
let substitution = " $0 IF NOT EXISTS (";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}