#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:-.*\n){3}-((?:.*\n(?!-+ Forwarded message).*)*)"
Local $sString = "-match one" & @CRLF & _
"-match two" & @CRLF & _
"-match three" & @CRLF & _
"-and a bunch of notes here, potentially with more than 1 line or newlines included " & @CRLF & _
"and there may be hyphens in this text as well" & @CRLF & _
"" & @CRLF & _
"This is a - text" & @CRLF & _
"" & @CRLF & _
"- match five" & @CRLF & _
"---------- Forwarded message ----------" & @CRLF & _
"From:...." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")