re = /^(?:-.*\n){3}-((?:.*\n(?!-+ Forwarded message).*)*)/m
str = '-match one
-match two
-match three
-and a bunch of notes here, potentially with more than 1 line or newlines included
and there may be hyphens in this text as well
This is a - text
- match five
---------- Forwarded message ----------
From:....
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end