import re
regex = re.compile(r"^(?:-.*\n){3}-((?:.*\n(?!-+ Forwarded message).*)*)", flags=re.MULTILINE)
test_str = ("-match one\n"
"-match two\n"
"-match three\n"
"-and a bunch of notes here, potentially with more than 1 line or newlines included \n"
"and there may be hyphens in this text as well\n\n"
"This is a - text\n\n"
"- match five\n"
"---------- Forwarded message ----------\n"
"From:....\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")