const regex = /^(?:-.*\n){3}-((?:.*\n(?!-+ Forwarded message).*)*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:-.*\\n){3}-((?:.*\\n(?!-+ Forwarded message).*)*)', 'gm')
const str = `-match one
-match two
-match three
-and a bunch of notes here, potentially with more than 1 line or newlines included
and there may be hyphens in this text as well
This is a - text
- match five
---------- Forwarded message ----------
From:....
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}