#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?iU)__t\(\s*["'](.*)["']\s*\)"
Local $sString = "alert(__t( 'Mingi tekst') ); " & @CRLF & _
"alert(__t("Mingi tekst") );" & @CRLF & _
"alert(__t( var_name ) );" & @CRLF & _
"__t('Mingi tekst') " & @CRLF & _
"function name() {" & @CRLF & _
" console.log(__t('sdfsdf'));" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"true ? __t( 'Mingi tekst' ) : __t( 'Teine tekst' ); " & @CRLF & _
"" & @CRLF & _
"$(el).html( __t( 'Tekst' ) + variable + '__t( 'Tekst' ) ); " & @CRLF & _
"" & @CRLF & _
"function( [ __t( 'tekst' ), __t( 'tekst2' ) ] );"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")