import Foundation
// WARNING: You included a flag that Swift doesn't support: U
// When this flag is set, it inverts the "greediness" of the quantifiers so that they are not greedy by default, but become greedy if followed by '?'.
// As an alternative, this effect can also be achieved by setting a (?U) modifier setting within the pattern or by a question mark behind a quantifier (e.g. .*?).
let pattern = #"__t\(\s*["'](.*)["']\s*\)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
alert(__t( 'Mingi tekst') );
alert(__t("Mingi tekst") );
alert(__t( var_name ) );
__t('Mingi tekst')
function name() {
console.log(__t('sdfsdf'));
}
true ? __t( 'Mingi tekst' ) : __t( 'Teine tekst' );
$(el).html( __t( 'Tekst' ) + variable + '__t( 'Tekst' ) );
function( [ __t( 'tekst' ), __t( 'tekst2' ) ] );
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)