re = /__t\(\s*["'](.*)["']\s*\)/i
str = 'alert(__t( \'Mingi tekst\') );
alert(__t("Mingi tekst") );
alert(__t( var_name ) );
__t(\'Mingi tekst\')
function name() {
console.log(__t(\'sdfsdf\'));
}
true ? __t( \'Mingi tekst\' ) : __t( \'Teine tekst\' );
$(el).html( __t( \'Tekst\' ) + variable + \'__t( \'Tekst\' ) );
function( [ __t( \'tekst\' ), __t( \'tekst2\' ) ] );'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end