import re
regex = re.compile(r"__t\(\s*[\"'](.*)[\"']\s*\)", flags=re.IGNORECASE)
test_str = ("alert(__t( 'Mingi tekst') ); \n"
"alert(__t(\"Mingi tekst\") );\n"
"alert(__t( var_name ) );\n"
"__t('Mingi tekst') \n"
"function name() {\n"
" console.log(__t('sdfsdf'));\n"
"}\n\n"
"true ? __t( 'Mingi tekst' ) : __t( 'Teine tekst' ); \n\n"
"$(el).html( __t( 'Tekst' ) + variable + '__t( 'Tekst' ) ); \n\n"
"function( [ __t( 'tekst' ), __t( 'tekst2' ) ] );")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")