#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)(?P<nom>^[\w\d]?)\/(?P<latfield>(?P<latflag>[NS])(?P<latval>\d{1,2}d[0-5]\d?(\.\d*)?))\/(?P<lonfield>(?P<lonflag>[EW])(?P<lonval>[01]?\d{1,2}d[0-5]\d?(\.\d*)?)$)"
Local $sString = "X/N45d54.56/W110d51.045"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")