use strict;
my $str = 'X/N45d54.56/W110d51.045';
my $regex = qr/(?P<nom>^[\w\d]?)\/(?P<latfield>(?P<latflag>[NS])(?P<latval>\d{1,2}d[0-5]\d?(\.\d*)?))\/(?P<lonfield>(?P<lonflag>[EW])(?P<lonval>[01]?\d{1,2}d[0-5]\d?(\.\d*)?)$)/sp;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}