using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<nom>^[\w\d]?)\/(?P<latfield>(?P<latflag>[NS])(?P<latval>\d{1,2}d[0-5]\d?(\.\d*)?))\/(?P<lonfield>(?P<lonflag>[EW])(?P<lonval>[01]?\d{1,2}d[0-5]\d?(\.\d*)?)$)";
string input = @"X/N45d54.56/W110d51.045";
RegexOptions options = RegexOptions.Singleline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}