const regex = new RegExp('(?P<nom>^[\\w\\d]?)\\/(?P<latfield>(?P<latflag>[NS])(?P<latval>\\d{1,2}d[0-5]\\d?(\\.\\d*)?))\\/(?P<lonfield>(?P<lonflag>[EW])(?P<lonval>[01]?\\d{1,2}d[0-5]\\d?(\\.\\d*)?)$)', 's')
const str = `X/N45d54.56/W110d51.045`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}