import Foundation
let pattern = #"(?P<nom>^[\w\d]?)\/(?P<latfield>(?P<latflag>[NS])(?P<latval>\d{1,2}d[0-5]\d?(\.\d*)?))\/(?P<lonfield>(?P<lonflag>[EW])(?P<lonval>[01]?\d{1,2}d[0-5]\d?(\.\d*)?)$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"X/N45d54.56/W110d51.045"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}