#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(?:(?:0?[0-9]|1[0-2])[\s:]?[0-5][0-9]\s?(?:[ap]m?)?|(?:[01][0-9]|2[0-3])[\s:]?[0-5][0-9]\s?(?:hr?)?)$"
Local $sString = "Valid Test Data:" & @CRLF & _
"" & @CRLF & _
"123" & @CRLF & _
"0345" & @CRLF & _
"1:23" & @CRLF & _
"03:45" & @CRLF & _
"123 a" & @CRLF & _
"123 am" & @CRLF & _
"1 23a" & @CRLF & _
"3:45 Am" & @CRLF & _
"3 45 pM" & @CRLF & _
"0345 h" & @CRLF & _
"0345 Hr" & @CRLF & _
"0345hR" & @CRLF & _
"" & @CRLF & _
"Invalid Test Data:" & @CRLF & _
"" & @CRLF & _
"123rr" & @CRLF & _
"123mm" & @CRLF & _
"2345Rr" & @CRLF & _
"12:45rR" & @CRLF & _
"234mm" & @CRLF & _
"2:34 mm" & @CRLF & _
"23 54 mm"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")