# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:(?:0?[0-9]|1[0-2])[\s:]?[0-5][0-9]\s?(?:[ap]m?)?|(?:[01][0-9]|2[0-3])[\s:]?[0-5][0-9]\s?(?:hr?)?)$"
test_str = ("Valid Test Data:\n\n"
"123\n"
"0345\n"
"1:23\n"
"03:45\n"
"123 a\n"
"123 am\n"
"1 23a\n"
"3:45 Am\n"
"3 45 pM\n"
"0345 h\n"
"0345 Hr\n"
"0345hR\n\n"
"Invalid Test Data:\n\n"
"123rr\n"
"123mm\n"
"2345Rr\n"
"12:45rR\n"
"234mm\n"
"2:34 mm\n"
"23 54 mm")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.