const regex = new RegExp('^(?:(?:0?[0-9]|1[0-2])[\\s:]?[0-5][0-9]\\s?(?:[ap]m?)?|(?:[01][0-9]|2[0-3])[\\s:]?[0-5][0-9]\\s?(?:hr?)?)$', 'gmi')
const str = `Valid Test Data:
123
0345
1:23
03:45
123 a
123 am
1 23a
3:45 Am
3 45 pM
0345 h
0345 Hr
0345hR
Invalid Test Data:
123rr
123mm
2345Rr
12:45rR
234mm
2:34 mm
23 54 mm`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}