use strict;
my $str = 'Valid Test Data:
123
0345
1:23
03:45
123 a
123 am
1 23a
3:45 Am
3 45 pM
0345 h
0345 Hr
0345hR
Invalid Test Data:
123rr
123mm
2345Rr
12:45rR
234mm
2:34 mm
23 54 mm';
my $regex = qr/^(?:(?:0?[0-9]|1[0-2])[\s:]?[0-5][0-9]\s?(?:[ap]m?)?|(?:[01][0-9]|2[0-3])[\s:]?[0-5][0-9]\s?(?:hr?)?)$/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}