import Foundation
let pattern = #"^(?:(?:0?[0-9]|1[0-2])[\s:]?[0-5][0-9]\s?(?:[ap]m?)?|(?:[01][0-9]|2[0-3])[\s:]?[0-5][0-9]\s?(?:hr?)?)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
Valid Test Data:
123
0345
1:23
03:45
123 a
123 am
1 23a
3:45 Am
3 45 pM
0345 h
0345 Hr
0345hR
Invalid Test Data:
123rr
123mm
2345Rr
12:45rR
234mm
2:34 mm
23 54 mm
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)