#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\$?([0-9]{1,3},([0-9]{3},)*[0-9]{3}|[0-9]+)(\.[0-9][0-9])?$"
Local $sString = "$500" & @CRLF & _
"$5,00" & @CRLF & _
"$5,000" & @CRLF & _
"$5.0" & @CRLF & _
"$5." & @CRLF & _
"$5.00" & @CRLF & _
"$5.000" & @CRLF & _
"$5,.5" & @CRLF & _
"500" & @CRLF & _
"5,000" & @CRLF & _
"5,00" & @CRLF & _
"5,0" & @CRLF & _
"5.0" & @CRLF & _
"5.00" & @CRLF & _
"5.000" & @CRLF & _
"5.23" & @CRLF & _
"2.342" & @CRLF & _
"$5,5,5" & @CRLF & _
"$5,000" & @CRLF & _
"$5,000,0" & @CRLF & _
"$5,000,00" & @CRLF & _
"$5,000,000" & @CRLF & _
"$5,0000"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")