// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\$?([0-9]{1,3},([0-9]{3},)*[0-9]{3}|[0-9]+)(\.[0-9][0-9])?$").unwrap();
let string = "$500
$5,00
$5,000
$5.0
$5.
$5.00
$5.000
$5,.5
500
5,000
5,00
5,0
5.0
5.00
5.000
5.23
2.342
$5,5,5
$5,000
$5,000,0
$5,000,00
$5,000,000
$5,0000";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}