using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\$?([0-9]{1,3},([0-9]{3},)*[0-9]{3}|[0-9]+)(\.[0-9][0-9])?$";
string input = @"$500
$5,00
$5,000
$5.0
$5.
$5.00
$5.000
$5,.5
500
5,000
5,00
5,0
5.0
5.00
5.000
5.23
2.342
$5,5,5
$5,000
$5,000,0
$5,000,00
$5,000,000
$5,0000";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}