$re = '/^\$?([0-9]{1,3},([0-9]{3},)*[0-9]{3}|[0-9]+)(\.[0-9][0-9])?$/m';
$str = '$500
$5,00
$5,000
$5.0
$5.
$5.00
$5.000
$5,.5
500
5,000
5,00
5,0
5.0
5.00
5.000
5.23
2.342
$5,5,5
$5,000
$5,000,0
$5,000,00
$5,000,000
$5,0000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);