package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\$?([0-9]{1,3},([0-9]{3},)*[0-9]{3}|[0-9]+)(\.[0-9][0-9])?$`)
var str = `$500
$5,00
$5,000
$5.0
$5.
$5.00
$5.000
$5,.5
500
5,000
5,00
5,0
5.0
5.00
5.000
5.23
2.342
$5,5,5
$5,000
$5,000,0
$5,000,00
$5,000,000
$5,0000`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}