import re
regex = re.compile(r"^\$?([0-9]{1,3},([0-9]{3},)*[0-9]{3}|[0-9]+)(\.[0-9][0-9])?$", flags=re.MULTILINE)
test_str = ("$500\n"
"$5,00\n"
"$5,000\n"
"$5.0\n"
"$5.\n"
"$5.00\n"
"$5.000\n"
"$5,.5\n"
"500\n"
"5,000\n"
"5,00\n"
"5,0\n"
"5.0\n"
"5.00\n"
"5.000\n"
"5.23\n"
"2.342\n"
"$5,5,5\n"
"$5,000\n"
"$5,000,0\n"
"$5,000,00\n"
"$5,000,000\n"
"$5,0000")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")